Search found 49 matches

by Redhouse
Thu Aug 26, 2021 05:36
Forum: Support
Topic: PHP upgrade 7.4 / 8.0
Replies: 3
Views: 443

Re: PHP upgrade 7.4 / 8.0

I got 7.4 working by using the error log for the site, and setting the site to the php version that breaks. Then I went through the log and fixed as many errors as I could followed by more investigation for the more difficult errors. For 7.3 whatever changes were required were fairly minimal so I'd ...
by Redhouse
Sun Jun 06, 2021 21:11
Forum: Support
Topic: PHP upgrade 7.4 / 8.0
Replies: 3
Views: 443

Re: PHP upgrade 7.4 / 8.0

I hacked a few pages to get the board to run on 7.4, although it's not thoroughly tested. The changes were: get_magic_quotes functions -> remove cases, where this was used and replaced with 0/false Functions with same name as their class -> change funtion name to '__construct' as a drop in replaceme...
by Redhouse
Thu Jun 03, 2021 02:15
Forum: Support
Topic: PHP upgrade 7.4 / 8.0
Replies: 3
Views: 443

PHP upgrade 7.4 / 8.0

I'm having some problems with the board upgrading to 7.4 (and 8.0). I've made some changes to get 7.3 working, but at 7.4 fast cgi I get an error log of : mod_fcgid: stderr: PHP Fatal error: Uncaught Error: Cannot pass parameter 2 by reference in /home/<USER>/<DOMAIN>/common/xajax/xajax.php:48 mod_f...
by Redhouse
Sat Nov 09, 2019 01:13
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

Well one argument is control, for example right now the image server is not serving up images properly. I notice some have the wrong top left corner identifier (eg. structure mod tag showing for ship equipment ), some images are not served up at all (eg. cyno ), and the tier identifier is not well s...
by Redhouse
Sat Nov 02, 2019 05:13
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

I noticed an issue with the ccp image server where requests like: https://image.eveonline.com/InventoryType/622_32.png would result in 'bad path' response, and no image. Changing to https://image.eveonline.com/Type/622_32.png gives the expected response I changed class.imageurl.php line 86 to $url ....
by Redhouse
Wed Aug 21, 2019 01:49
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

Everything appears to be working, it was just a coincidence for me that I decided to upgrade right as that bug was present.
by Redhouse
Fri Aug 16, 2019 20:45
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

Not a huge problem. Thanks for finding the root cause and looking into a potential fix.
by Redhouse
Fri Aug 16, 2019 13:51
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

Awsome, thanks.
by Redhouse
Fri Aug 16, 2019 04:32
Forum: General Killboard Chat
Topic: EDK 4.4.3.0 (July 2019 1.0)
Replies: 23
Views: 62933

Re: EDK 4.4.3.0 (July 2019 1.0)

Hi, I'm having some trouble with this. The update installs without error to 4.4.3.0 in my case but after doing so I'm not able to post a killmail. Posting the mail returns an empty page. I searched around google for some edk boards and tried to post a mail to them and they all gave the same result (...
by Redhouse
Wed Jan 02, 2019 02:04
Forum: General Killboard Chat
Topic: EDK 4.4.2.0 (Onslaught 1.0)
Replies: 15
Views: 26099

Re: EDK 4.4.2.0 (Onslaught 1.0)

Looks to be working fine for me. Thanks.