EDK 4.2.0.0 (Rubicon 1.3)

EDK releases + Open discussion and chat about EDK.
User avatar
Salvoxia
Developer
Posts: 1598
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Salvoxia » Sun Apr 27, 2014 08:23

Hi,

looks like the boards have a problem with API calls in general.
Try this: http://www.evekb.org/forum/viewtopic.ph ... =10#p48020

Regards,
Salvoxia

Bashir
Noob
Posts: 6
Joined: Sat Jun 08, 2013 01:12

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Bashir » Sun Apr 27, 2014 21:18

Just wanted to pass on my thanks to you all for working on this, installed it 2 days after release without any problems.

the new features are great (CREST), can't wait for 4.3 and Zboard feedsync? :)

Subsparx
Noob
Posts: 9
Joined: Sat Aug 17, 2013 00:10

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Subsparx » Mon Apr 28, 2014 05:31

That fixed it for me Salvoxia, both boards are now functioning correctly. Thank you.

User avatar
DarkArchon
Someday Author
Posts: 83
Joined: Wed Feb 25, 2009 22:16

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by DarkArchon » Mon Apr 28, 2014 20:25

Bug that happened to me, not sure if anyone else has seen this. I went to update my board and it started running through the process. It got to this page...

Code: Select all

banner
Update
Reading packages...Inserting data (4/32) into kb3_dgmtypeattributes
using file packages/database/kb3_dgmtypeattributes/sql_tbldata_dgmtypeattributes.sql.gz...

File packages/database/kb3_dgmtypeattributes/sql_tbldata_dgmtypeattributes.sql.gz had 11 lines with 11 queries.
0 Queries failed.

Finished importing of this file.
Automatic reload in 1s for next chunk. Manual Link
©2006-2010 EVE Development Network
and then went to my sites 404 page, the url

Code: Select all

/eve/kb/update/'
Note the ' at the end

The time between it hitting that page and redirecting to the 404 is too quick to click the manual link but I can remove the ' and get that page back, but I was able to ctrl+c to get the above text and view the source. From there I saw the manual link

Code: Select all

<a href="?package=CCPDB">Manual Link</a>
so I appended that to my URL /eve/kb/update/?package=CCPDB and off it went! Which I'm really thankful for because I got tired of doing DB backups and reading documentation years ago :P Everything seems to be in order so far.

You broke my mod though :( I'll look at it when I get time, but as you can see by the original thread, I can't take any credit for the original work. So if anyone knows how to fix it please let me know.

User avatar
Salvoxia
Developer
Posts: 1598
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Salvoxia » Mon Apr 28, 2014 20:37

Hi,

glad to see you surfacing once again :D

The problem you described is listed as the first "known issue" in the OP (at the bottom), including a link to a fix :)

And basically, the mod is not broken, the modified core files simply got updated. But the modifications done to them would work just the same in EDK 4.2.
I already took a quick look at the code, doesn't look like a big problem. I'd very much like to assist you, shoot me a PM if you like!

Regards,
Salvoxia

User avatar
DarkArchon
Someday Author
Posts: 83
Joined: Wed Feb 25, 2009 22:16

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by DarkArchon » Tue Apr 29, 2014 01:31

I'm glad I read all those "known issue" warnings and backups and stuff before I just go clicking apply to random patches :P I hate users like me :(

Thanks for the offer to help too, the mod problem turned out to be much smaller than I expected though. It doesn't look like any of the common files I used got changed, just some template issues. If you feel like checking to make sure I didn't miss anything and your KB doesn't catch on fire I would very much appreciate it, but I don't think it's necessary.

User avatar
Salvoxia
Developer
Posts: 1598
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Salvoxia » Tue Apr 29, 2014 07:17

Yeah well, I didn't even check if any of the core files had been touched :P
I was directly looking at a method without having to replace class.killlisttable.php

User avatar
Luteros
Greenhorn
Posts: 10
Joined: Wed Dec 05, 2012 18:57

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Luteros » Wed May 07, 2014 15:09

Except from the known issue - that was pretty easy to fix - upgrade went smoothly.

Thank you for your continuous and awesome work on the EDK!

User avatar
Luteros
Greenhorn
Posts: 10
Joined: Wed Dec 05, 2012 18:57

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Luteros » Tue May 13, 2014 20:32

I also have the "cant connect to API" issue with CREST Links because allow_url_fopen is off. I'm on hosted webspace and can't modify the php.ini is there a chance we can get a curl Version because that works fine?

User avatar
Salvoxia
Developer
Posts: 1598
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.0.0 (Rubicon 1.3)

Post by Salvoxia » Wed May 14, 2014 08:03

Hi,

shouldn't be a problem, will take a look at it!

Regards,
Salvoxia

Post Reply

Return to “General Killboard Chat”

Who is online

Users browsing this forum: No registered users and 3 guests