EDK 4.2.20.0 and apache 2.4

EDK releases + Open discussion and chat about EDK.
Post Reply
unrealalex
Greenhorn
Posts: 13
Joined: Wed Jan 13, 2010 18:37

EDK 4.2.20.0 and apache 2.4

Post by unrealalex » Fri Mar 11, 2016 22:50

in apache 2.4 config files syntax and many other change, but in .htaccess files in KB and mod found:
deny from all
in apache 2.4 this directive replace to:
Require all denied

because of this in the Apache 2.4 KB is not working properly.
Will you fix this?

PS Sorry for my English...

User avatar
Salvoxia
Developer
Posts: 1591
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.20.0 and apache 2.4

Post by Salvoxia » Sat Mar 12, 2016 15:21

Hi,

thanks for the heads up!
The problem is that we don't know what webserver version everyone will be using, so if we change it to work correctly with Apache 2.4, it won't work anymore with older versions. So that's a bit of a dilemma. At least for Apache 2.4 there is the mod_access_compat that restores compatibility.
If you have any suggestions on how to solve this, I'm open to ideas :)

Best Regards,
Salvoxia

Post Reply

Return to “General Killboard Chat”

Who is online

Users browsing this forum: No registered users and 5 guests