EDK 4.2.29.0 (YC-119.1 1.0)

EDK releases + Open discussion and chat about EDK.
Explorus
Greenhorn
Posts: 22
Joined: Thu Oct 18, 2012 08:20

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Explorus » Tue Feb 28, 2017 21:24

Same problem!
"Invalid format for kill, skipping"

User avatar
Salvoxia
Developer
Posts: 1518
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Salvoxia » Wed Mar 01, 2017 00:21

Hi,

apparently they did change something, thanks for reporting!

I'll just do a quick write-up for a workaround, right now that's all my time permits (I'll push a hotfix tomorrow):
open common/includes/class.zkbfetch.php and find the following block of code (shold be around line 329):

Code: Select all

// force API verified mails only
if(strpos($this->fetchUrl, 'api-only') === FALSE)
{
	$this->fetchUrl .= 'api-only/';
}
Remove this block completely.

This should help (not tested myself, though!).

Best Regards,
Salvoxia

Explorus
Greenhorn
Posts: 22
Joined: Thu Oct 18, 2012 08:20

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Explorus » Wed Mar 01, 2017 09:02

Thanks, working fine for me now :)

delakut
Greenhorn
Posts: 26
Joined: Sun Oct 16, 2011 10:40

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by delakut » Wed Mar 01, 2017 10:45

I deleted the "force API verified mails only" block and I started to download from the 2017-02-01. I still got the error messages below. If I skip the last invalid kill timestamp for one hour it runs to the next "Invalid format for kill".
ZKBApi: https://zkillboard.com/api/corporationID/155453528/
0 kills were posted and 0 were skipped (1 kills fetched). Timestamp of last kill: 2017-02-19 11:50:36
Invalid format for kill, skipping
ZKBApi: https://zkillboard.com/api/corporationID/155453528/
0 kills were posted and 0 were skipped (1 kills fetched). Timestamp of last kill: 2017-02-26 22:34:28
Invalid format for kill, skipping

User avatar
Salvoxia
Developer
Posts: 1518
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Salvoxia » Wed Mar 01, 2017 12:07

Did it work at least once after you made the change, or didn't the change affect the result at all?

delakut
Greenhorn
Posts: 26
Joined: Sun Oct 16, 2011 10:40

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by delakut » Wed Mar 01, 2017 13:29

hmm, I'm not hundred percent sure. I think I first got only the 27. after I made the change and not the 28. After that I deleded the cache and got the 28. too. I can't exactly reproduce it anymore. That was the reason why I started to fetched all kills from 01.02 because I wasn't sure when the problem started.

User avatar
Salvoxia
Developer
Posts: 1518
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Salvoxia » Wed Mar 01, 2017 17:35

Hi,

I now tested and pushed the fix posted above: https://github.com/evekb/evedev-kb/comm ... 54ecc82b25

@delakut: I tested fetching for your corp, works fine on my test board:

Code: Select all

ZKBApi: https://zkillboard.com/api/corporationID/155453528/
0 kills were posted and 3 were skipped (3 kills fetched). Timestamp of last kill: 2017-02-28 20:43:39
Could you please double-check the changes above and if that does not reveal anything helpful, please attach your class.zkbfetch.php so I can test with it.

Best Regards,
Salvoxia

delakut
Greenhorn
Posts: 26
Joined: Sun Oct 16, 2011 10:40

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by delakut » Wed Mar 01, 2017 18:31

It works now. I replaced my file with the original EDK4.2.29.0 and deleted the linies again. Maybe I still had another quickfix in there which caused the problem. Thank you for your help.

Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Bas » Fri Mar 03, 2017 22:56

Salvoxia wrote:
Wed Mar 01, 2017 00:21
I'll just do a quick write-up for a workaround, right now that's all my time permits (I'll push a hotfix tomorrow):
open common/includes/class.zkbfetch.php and find the following block of code (shold be around line 329):

Code: Select all

// force API verified mails only
if(strpos($this->fetchUrl, 'api-only') === FALSE)
{
	$this->fetchUrl .= 'api-only/';
}
Remove this block completely.
now works for me too, tnx!

User avatar
Salvoxia
Developer
Posts: 1518
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.2.29.0 (YC-119.1 1.0)

Post by Salvoxia » Thu Mar 16, 2017 18:45

prometh wrote:
Mon Feb 20, 2017 11:48

hmmm its actually in the code and I'm not exactly sure why its no longer working, anyway it requires a change to your theme file to get it working again. open the killlisttable.tpl for the theme you are using and find the following line, should be around line 79 (for the default theme):
I tried to trace that change using the file's history, but it seems it has always been like this. So I guess I'll just apply that same fix.

Best Regards,
Salvoxia

Post Reply

Return to “General Killboard Chat”

Who is online

Users browsing this forum: No registered users and 1 guest