EDK 4.4.0.0 with ESI support

EDK releases + Open discussion and chat about EDK.
User avatar
Salvoxia
Developer
Posts: 1528
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.4.0.0 with ESI support

Post by Salvoxia » Thu May 31, 2018 09:08

Well, if you absolutely cannot wait, here's the link to the standalone database update ;) : Download (MD5: B13C3ADED9E7BC5B916FC32C2CB1A0ED)

User avatar
Rounon Dax
Greenhorn
Posts: 21
Joined: Sat Jul 11, 2015 17:15

Re: EDK 4.4.0.0 with ESI support

Post by Rounon Dax » Mon Jun 11, 2018 13:00

Getting another error while trying to import these killmails:
https://zkillboard.com/kill/70527338/
https://zkillboard.com/kill/70527393/

Error:

Code: Select all

[Mon Jun 11 12:43:17.746315 2018] [fcgid:warn] [pid 27490:tid 140002971330304] [client 212.95.112.48:57612] mod_fcgid: stderr: PHP Fatal error:  Uncaught Swagger\\Client\\ApiException: [400] Error connecting to the API (https://esi.evetech.net/v2/corporations/names/?corporation_ids=1000046%2C610914338%2C98415266%2C98473977%2C98558219%2C98362674%2C98248053%2C98498181%2C98527509%2C1000170%2C150773179%2C98388312%2C1187207583%2C679900455%2C98490588%2C98545297%2C98332366%2C98412085%2C98494995%2C98169165%2C1692326236%2C424525976%2C98436676%2C98539257%2C98292149%2C98180098%2C98177721%2C1000168%2C1000111%2C98502659%2C98451868%2C1431056470%2C98403825%2C98466921%2C1000009%2C98524280%2C98561878%2C98521871%2C98434129%2C1000166%2C98509133%2C98427837%2C1000014%2C1878184099%2C427125032%2C98550674%2C98540469%2C1322941905%2C917701062%2C1000066%2C98456012%2C98257506%2C98507722%2C98492492%2C98129875%2C98145916%2C481995776%2C98217378%2C98459440%2C98527814%2C98481112%2C98526875%2C754312156%2C98423767%2C1890620422%2C98492660%2C98548212%2C773499566%2C1000072%2C1817310770%2C98102686%2C98526346%2C98036208%2C98330748%2C98549540%2C98148549%2C1699307293%2C98033556%2C98171048%2C984 in /var/www/yulaifederation/webroot/kb.yulaifederation.net/common/includes/esi/class.esi.php on line 255, referer: https://kb.yulaifederation.net/?a=post
When I am opening the ESI URL in a browser, everything looks nice though ...

User avatar
Ariea Thellare
Noob
Posts: 8
Joined: Mon May 14, 2018 03:12

Re: EDK 4.4.0.0 with ESI support

Post by Ariea Thellare » Tue Jun 19, 2018 02:03

well, thanks to
https://developers.eveonline.com/blog/a ... tion-names
neither zkb nor esi will fetch anything regardless of problems with the triglavian stuff.
cause breaking updates are awesome updates

btw could i just take the version from the 4.4-dev github branch and manually upgrade with that?

tareel_jax
Noob
Posts: 1
Joined: Tue Jun 19, 2018 12:53

Re: EDK 4.4.0.0 with ESI support

Post by tareel_jax » Tue Jun 19, 2018 12:55

Does anyone else gets this when fetching zkb ?

2018/06/19 10:50:12 - [404] Error connecting to the API (https://esi.evetech.net/v1/characters/n ... xxxxxxxxxx)

EDIT: the same for fetching esi.

User avatar
Salvoxia
Developer
Posts: 1528
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.4.0.0 with ESI support

Post by Salvoxia » Tue Jun 19, 2018 16:00

Hi,

sorry for my long silence in this thread, I have been on a very busy business trip.

Thank you for heads up!
We all love breaking changes, fortunately there is a quite easy hotfix for this problem, since almost everything that is needed is already there.
The fix looks like this: https://github.com/evekb/evedev-kb/comm ... 3d69f4512d
The upside of that change is that it should speed up killmail posting quite a bit. In the worst case, two less ESI requests need to be performaed per kill .

@Ariea Thellare: Yes, you could update from the dev branch. My colleague, who used to create the update packages, seems to have dropped off the world (hopefully just a long vacation), if he doesn't show soon I'll look it taking over that as well.

Best Regards,
Salvoxia

Redhouse
Greenhorn
Posts: 39
Joined: Sun Mar 18, 2012 17:12

Failure to post

Post by Redhouse » Wed Jun 20, 2018 07:11

I noticed just around the time of this post that my boards (and a number of other EDK boards) running 4.4.0.0 are returning a blank page after submitting an ESI killmail link (no new modules or hulls). I confirmed the esi link returning actual data from eve, it looked ok. I grabbed a few new killmails from zkillboard and tested them, they also gave the same result. Do you have any idea what might be causing this?
-------
I applied the hotfix above to common/includes/class.esiparser.php and common/includes/esi/class.helpers.php and the problem seems to have gone away.

User avatar
Ariea Thellare
Noob
Posts: 8
Joined: Mon May 14, 2018 03:12

Re: EDK 4.4.0.0 with ESI support

Post by Ariea Thellare » Tue Jun 26, 2018 01:28

@Salvoxia
what version of the codegen did you use, to generate the esi php client?
I tried using POST/universe/names for one of my projects and can get it working for the life of me.
So I am using more or less the same data structures as you i thought maybe you used a different codegen version than I(2.3.1)

Or what kind of parameters/configs are you using for the codegen command?

User avatar
Salvoxia
Developer
Posts: 1528
Joined: Wed Feb 22, 2012 12:11

Re: EDK 4.4.0.0 with ESI support

Post by Salvoxia » Tue Jun 26, 2018 16:44

Hi,

I use the command line version of Swagger Codegen 2.2.1 with these arguments:

Code: Select all

java -jar swagger-codegen-cli.jar generate --api-package EsiClient -i https://esi.tech.ccp.is/_latest/swagger.json?datasource=tranquility -l php
Best Regards,
Salvoxia

User avatar
Rounon Dax
Greenhorn
Posts: 21
Joined: Sat Jul 11, 2015 17:15

Re: EDK 4.4.0.0 with ESI support

Post by Rounon Dax » Sun Jul 01, 2018 09:10

zKillboard Import stopped working a couple of days ago for me.
ZKBApi: https://zkillboard.com/api/allianceID/99000102/
0 kills were posted and 0 were skipped (1 kills fetched). Timestamp of last kill: 2018-06-27 22:00:00
Invalid format for kill, skipping
No matter what date I am giving it, it doesn't do anything besides giving me this message.

User avatar
Dism0
Active Author
Posts: 152
Joined: Fri Jul 06, 2012 01:42

Re: EDK 4.4.0.0 with ESI support

Post by Dism0 » Wed Jul 04, 2018 22:39

just so everyone knows there is an update available in the admin panel to 4.4.1.0. it fixes the esi/zkb pulling kills too.

Post Reply

Return to “General Killboard Chat”

Who is online

Users browsing this forum: No registered users and 8 guests