signature images

Help and support in getting the EVE-Dev Killboard to run on your site.
Post Reply
User avatar
Dism0
Active Author
Posts: 144
Joined: Fri Jul 06, 2012 01:42

signature images

Post by Dism0 » Mon Oct 09, 2017 00:25

im not 100% sure when this started. it may have something to do when i changed host and starting using a more modern php, but im not sure at all. so when i go to the profile of a pilot (namely myself) i get the signature page without any of the normal pictures.

Image

typically just copy and link and it'd work but when i paste the link into a browser i get the following:

Code: Select all

http://sltkcorp.com/kb/?a=sig&i=7&s=apoc

Code: Select all

DEPRECATED [8192] Non-static method Pilot::getPortraitPath() should not be called statically
Error on line 73 in file /homepages/30/d678292045/htdocs/kb/mods/signature_generator/signatures/apoc/apoc.php
PHP 7.0.23 (Linux), EDK 4.2.34.0 (YC-119-8 1.0)
File: /homepages/30/d678292045/htdocs/kb/mods/signature_generator/signatures/apoc/apoc.php, line: 73, class: EDKError, function: handler
File: /homepages/30/d678292045/htdocs/kb/mods/signature_generator/sig.php, line: 121, function: require
File: /homepages/30/d678292045/htdocs/kb/common/index.php, line: 319, function: include
File: /homepages/30/d678292045/htdocs/kb/index.php, line: 25, function: include

ERROR [256] An error occured. Content has already been sent.

Error on line 127 in file /homepages/30/d678292045/htdocs/kb/mods/signature_generator/sig.php
PHP 7.0.23 (Linux), EDK 4.2.34.0 (YC-119-8 1.0)
File: /homepages/30/d678292045/htdocs/kb/mods/signature_generator/sig.php, line: 127, function: trigger_error
File: /homepages/30/d678292045/htdocs/kb/common/index.php, line: 319, function: include
File: /homepages/30/d678292045/htdocs/kb/index.php, line: 25, function: include
now i know the first one is due to the php but the 2nd one im not sure of why im getting that error. any suggestions?

User avatar
Salvoxia
Developer
Posts: 1431
Joined: Wed Feb 22, 2012 12:11

Re: signature images

Post by Salvoxia » Mon Oct 09, 2017 08:07

Hi,

yes, the Signature Generator mod still seems to have code that doesn't work with PHP 7.x.
The second error is subsequent to the first one, caused by a command that requires no other output before the command is called. Since PHP printed the error message about the statically called method, that command now complains.
I will go over the mod and fix this.

Best Regards,
Salvoxia

User avatar
Dism0
Active Author
Posts: 144
Joined: Fri Jul 06, 2012 01:42

Re: signature images

Post by Dism0 » Mon Oct 09, 2017 10:33

well that makes me feel a little better that it's not something that i did when moving the killboard. :D


Image

User avatar
Salvoxia
Developer
Posts: 1431
Joined: Wed Feb 22, 2012 12:11

Re: signature images

Post by Salvoxia » Mon Oct 09, 2017 17:32


User avatar
Dism0
Active Author
Posts: 144
Joined: Fri Jul 06, 2012 01:42

Re: signature images

Post by Dism0 » Thu Oct 12, 2017 02:11

works great! thanks!


Image

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests