switching from php5.6 to php7

Help and support in getting the EVE-Dev Killboard to run on your site.
Post Reply
Tupsi
Noob
Posts: 4
Joined: Mon Jan 19, 2009 12:15

switching from php5.6 to php7

Post by Tupsi » Tue Jan 09, 2018 17:47

After searching the forum for php7 I came to the conclusion that the killboard should work with php7 these days (already tried switching a few times, but it never worked so far). Sadly still doesnt work here. When I switch from my nginx php 5 upstream to 7 I get the following error and the browser only see a white page (as server throws a 500er).

Code: Select all

2018/01/09 15:35:11 [error] 3197#3197: *5675498 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined method Event::register() in /var/www/killboard/common/xajax/xajax.php:12
Stack trace:
#0 /var/www/killboard/common/index.php(201): require_once()
#1 /var/www/killboard/index.php(25): include('/var/www/killbo...')
#2 {main}
  thrown in /var/www/killboard/common/xajax/xajax.php on line 12" while reading response header from upstream, client: [myipaadress], server: [myserver], request: "GET /?a=home HTTP/2.0", upstream: "fastcgi://unix:/run/php/php7.0-fpm.sock:", host: "[myhost]"
I read that some mods still have issues, so I even tried pulling a fresh clone from github and even deleted all mods, but the errors persists.

Any idea what I am missing here?

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 8 guests