zbb fetch

Help and support in getting the EVE-Dev Killboard to run on your site.
Post Reply
exo
Noob
Posts: 2
Joined: Thu Mar 23, 2017 19:55

zbb fetch

Post by exo » Thu Mar 23, 2017 20:02

Hello, I've been unable to find a solution by myself for the zkb fetch.
Here are the details I can provide:


Using last available build: EDK 4.2.29.0
Fresh install, only the DB is old (got it from previous site owner).
Link to kb: http://eyesfrcorp.cluster023.hosting.ovh.net/edk/ (domain name not yet transferred to new host)


String used for zkb API: https://zkillboard.com/api/corporationID/98017240/
Timestamp used : I have used several ones (from 1-2 days old to 2-3 months old, but the result is always the same) at all time with round hours (00)

Ouptut when run from admin panel:

ZKBApi: https://zkillboard.com/api/corporationID/98017240/
0 kills were posted and 0 were skipped (1 kills fetched). Timestamp of last kill: 2017-02-28 16:00:00
Invalid format for kill, skipping


Output when running from console:

$ /usr/local/bin/php ./www/edk/cron/cron_zkb.php
X-Powered-By: PHP/5.4.45
Content-type: text/html
2017/03/23 17:30:46 - Starting zKB Import
2017/03/23 17:30:46 - Error reading feed: https://zkillboard.com/api/corporationID/98017240/
2017/03/23 17:30:46 - Error getting data: (7), Start time = 2017-02-28 16:00:00
2017/03/23 17:30:46 - Time taken = 0.061151027679443 seconds.
$

Any idea ?

exo
Noob
Posts: 2
Joined: Thu Mar 23, 2017 19:55

Re: zbb fetch

Post by exo » Thu Mar 23, 2017 21:09

OK, I found out (didnt go far enough on the release topic ^^), I'll let the info here in case some other people have the same issue.

The solution provided by Salvoxia:

In the /common/include/class.zkbfetch.php file, comment/remove the whole "force API verified mails only" (that's a block of 3 lines around line 329).

Now it works :D

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests