[solved]clean install fails

Help and support in getting the EVE-Dev Killboard to run on your site.
Post Reply
giantjack
Greenhorn
Posts: 10
Joined: Sat Nov 09, 2013 03:30

[solved]clean install fails

Post by giantjack » Fri Feb 22, 2019 20:48

newest edit: solved with sql command: SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY',''));

new EDIT:
install worked but killboard is not working:
http://wombo.tk/

Code: Select all

Database error: Expression #1 of ORDER BY clause is not in SELECT list, references column 'kb.ina.ina_timestamp' which is not in SELECT list; this is incompatible with DISTINCT
SQL: SELECT DISTINCT kll_id FROM kb3_kills kll STRAIGHT_JOIN kb3_ships shp ON ( shp.shp_id = kll.kll_ship_id ) STRAIGHT_JOIN kb3_ship_classes scl ON ( scl.scl_id = shp.shp_class ) INNER JOIN kb3_inv_all ina ON (ina.ina_kll_id = kll.kll_id) WHERE ina.ina_all_id in (1 ) AND ina.ina_timestamp >= '2019-02-18 00:00:00' AND ina.ina_timestamp <= '2019-02-24 23:59:59' AND shp.shp_class not in ( 2,3,11,53 ) order by ina.ina_timestamp desc
apache error log:

Code: Select all

[Fri Feb 22 19:01:36.575067 2019] [php7:notice] [pid 15837] [client xxx:53648] PHP 256:  SQL error (Expression #1 of ORDER BY clause is not in SELECT list, references column 'kb.ina.ina_timestamp' which is not in SELECT list; this is incompatible with DISTINCT in /var/www/html/common/includes/class.dbnormalquery.php on line 46, referer: http://wombo.tk/install/?step=8
-----------------------------------------------------------------------------------------------------------------------------------



OS: Ubuntu 18.04.1 LTS
MySQL: 5.7.25
PHP: 7.2.15

step 3 looks good
s3.PNG
s3.PNG (154.81 KiB) Viewed 858 times
but step 4 is not working:
s4.PNG
(164.97 KiB) Not downloaded yet
Image

apache error log:

Code: Select all

[Fri Feb 22 18:40:52.291378 2019] [php7:warn] [pid 13757] [client xxx:53401] PHP Warning:  Use of undefined constant cacheWriteable - assumed 'cacheWriteable' (this will throw an Error in a future version of PHP) in /var/www/html/install/index.php on line 36, referer: http://wombo.tk/install/?step=3
[Fri Feb 22 18:40:52.296400 2019] [php7:error] [pid 13757] [client xxx:53401] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/common/includes/class.xml.php:24\nStack trace:\n#0 /var/www/html/install/install_step4.php(27): sxml->parse('<?xml version="...')\n#1 /var/www/html/install/index.php(80): include('/var/www/html/i...')\n#2 {main}\n  thrown in /var/www/html/common/includes/class.xml.php on line 24, referer: http://wombo.tk/install/?step=3
edit: solved with "apt-get install php-xml"

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests