zKillboard Import after April patch.

Help and support in getting the EVE-Dev Killboard to run on your site.
Post Reply
FlashAM
Greenhorn
Posts: 11
Joined: Sat Feb 06, 2010 00:28

zKillboard Import after April patch.

Post by FlashAM » Thu Apr 11, 2019 04:59

Is anyone having trouble getting killmails imported after the patch?

If I do a manual fetch from within the killboard admin page I get Error reading feed: https://zkillboard.com/api/characterID/XXXXXXXXXXX/, Start time = 1554345964

If I call the .php from the command line I get this:

2019/04/11 02:30:01 - Starting zKB Import
[WARNING] Endpoint https://esi.evetech.net/v2/universe/names/ warning: 299 -
This route is deprecated
PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried
to allocate 16384 bytes) in
/var/www/flasham/common/includes/class.dbnormalquery.php on line 36

Anyone experiencing the same thing or do I have something set up incorrectly? It has been working for months up until patch day. Any help would be appreciated.

Flash

FlashAM
Greenhorn
Posts: 11
Joined: Sat Feb 06, 2010 00:28

Re: zKillboard Import after April patch.

Post by FlashAM » Fri Apr 12, 2019 15:17

I'm not sure if anyone is still supporting this software, since I haven't gotten any responses. I've checked a number of things on my billboard site. I've reinstalled the databases through the admin page. I've checked the mysql logs on the server (no errors). I was doing some research on the .php error and even increased the memory usage from 1GB to 2GB. None have yielded a solution. I've also tried getting the ESI Link from a kill mail that has not been auto posted and copied the information to post it manually. It states the kill mail is malformed:

Killmail is malformed.
Error: Timestamp is not accurate to the second, cannot post kill. Please use CREST!

I'm guessing either something changed with CCP's kill mails or something changed on zKillboard's side.

ANY help would be appreciated.

FlashAM
Greenhorn
Posts: 11
Joined: Sat Feb 06, 2010 00:28

Re: zKillboard Import after April patch.

Post by FlashAM » Sat Apr 13, 2019 05:00

After doing some more digging, the error with posting of the killmails includes killmails BEFORE the patch, so that was probably a pre-existing issue. However, I've located where the zkillboard pull stops for me. It's in the class.esiparser.php on line 103.

if($checkHash->recordCount())

There is nothing else happening after this. I hope maybe this gives someone an idea of what might be going on and be able to help me solve the issue. Right now my killboard is useless as no killmails can be pulled.

User avatar
Salvoxia
Developer
Posts: 1591
Joined: Wed Feb 22, 2012 12:11

Re: zKillboard Import after April patch.

Post by Salvoxia » Sun Apr 14, 2019 10:41

Hi,

sorry for my little late reply.
Please check the bottom of the last version's release post (http://www.evekb.org/forum/viewtopic.php?f=503&t=22081) for the known issues.
Sounds like the hotfix for issue #1 could help you.

TBH I've been waiting for a new SDE from CCP after the April patch to include in an updated versions, but nothing so far...

Best Regards,
Salvoxia

FlashAM
Greenhorn
Posts: 11
Joined: Sat Feb 06, 2010 00:28

Re: zKillboard Import after April patch.

Post by FlashAM » Sun Apr 14, 2019 18:49

That was the solution!! I had no idea there was one of the standup facilities on one of the killmails! Killboard is now working again!

Thank you very much for your help Salvoxia!!!!

I hope you get the information from CCP soon, you have a great product and I've been using it for years. It's so much cleaner than zkb, in my opinion.

Thanks again,

Flash

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests