Zkb fetch error

Help and support in getting the EVE-Dev Killboard to run on your site.
anchorhead
Someday Author
Posts: 95
Joined: Thu May 16, 2013 12:48

Zkb fetch error

Post by anchorhead » Sun May 19, 2019 15:50

Hello,

When i want to fetch zkb i have this error :
Error reading feed: https://zkillboard.com/api/allianceID/99002819/
Both startime and endtime are required when one or the other is given, Start time = 2018-05-11 17:00:00


Thanks
Last edited by anchorhead on Sun May 19, 2019 21:48, edited 1 time in total.

raykai
Noob
Posts: 5
Joined: Sun May 19, 2019 16:34

Re: Zkb fetch error

Post by raykai » Sun May 19, 2019 16:35

im haveing the same prob with Zkb

anchorhead
Someday Author
Posts: 95
Joined: Thu May 16, 2013 12:48

Re: Zkb fetch error

Post by anchorhead » Sun May 19, 2019 16:41

I have 3 kb, yesterday i did a kill, this kill should be on this 3 kb, 1/3 kb have this kill.

But kb who have this kill don't want fetch also, i don't understand ...

Nothing settings change on kb

FlashAM
Greenhorn
Posts: 11
Joined: Sat Feb 06, 2010 00:28

Re: Zkb fetch error

Post by FlashAM » Sun May 19, 2019 21:37

Same problem here as well. Just started last night. zKB must have done some kind of update.

anchorhead
Someday Author
Posts: 95
Joined: Thu May 16, 2013 12:48

Re: Zkb fetch error

Post by anchorhead » Sun May 19, 2019 21:47

I have sent an eve mail to Salvoxia

User avatar
Salvoxia
Developer
Posts: 1593
Joined: Wed Feb 22, 2012 12:11

Re: Zkb fetch error

Post by Salvoxia » Mon May 20, 2019 17:11

Hi,

thank you for notifying me :)

A hotfix for this issue is now available, please see here: http://www.evekb.org/forum/viewtopic.ph ... 725#p50725

Best Regards,
Salvoxia

raykai
Noob
Posts: 5
Joined: Sun May 19, 2019 16:34

Re: Zkb fetch error

Post by raykai » Mon May 20, 2019 17:50

i did the fix but its not getting all the kills.
Im on a fresh install and i put Fetch Begin Timestamp as 2017.10.21 but its only getting 9 kills even if there are many on https://zkillboard.com/corporation/98533953/

its like its not Fetching from the Begin Timestamp but only start on the day of the Last Kill Timestamp...

User avatar
Salvoxia
Developer
Posts: 1593
Joined: Wed Feb 22, 2012 12:11

Re: Zkb fetch error

Post by Salvoxia » Mon May 20, 2019 18:07

Hey,

for zKBFetch to fetch all kills for a specific entity, you have to manually set the last kill timestamp to the first kill timestamp that zKB knows of (in your case that's 2017-10-22 02:00:00).
Then start fetching. EDK will work its way through each day until it arrives in the present, one day for each cycle.

Unfortunately, that's currently the only way to do it. I'll try to look into optimizing the logic (e.g. continuing to fetch automatically, but without hitting the maximum execution time).

Best Regards,
Salvoxia

raykai
Noob
Posts: 5
Joined: Sun May 19, 2019 16:34

Re: Zkb fetch error

Post by raykai » Mon May 20, 2019 18:16

kb.PNG
kb.PNG (517.33 KiB) Viewed 2351 times
still saying 0 kills were posted and 1 were skipped.
maybe im doing something wrong?

User avatar
Salvoxia
Developer
Posts: 1593
Joined: Wed Feb 22, 2012 12:11

Re: Zkb fetch error

Post by Salvoxia » Mon May 20, 2019 18:43

Kills will be skipped if they are already posted, if there is a date restriction for kills (see Posting Options) or if they are NPC only losses and filtered out due to that.

When I tested posting this kill, it got filtered out due to being an NPC only loss. When I disabled that setting and re-set the last kill timestamp, it posted.
Can you confirm that this skill is indeed not already posted?

Best Regards,
Salvoxia

Post Reply

Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests