Augmented Banner - now works with EDK 4.0.3

Discuss/Upload mods to the EVE-Dev Killboard.
someone
Noob
Posts: 1
Joined: Tue Dec 28, 2010 14:57

Re: Augmented Banner - now works with EDK 4.0.3

Post by someone » Sat Jun 22, 2013 14:49

i've implemented that mod like below;

Code: Select all

                <div id="augmented_banner" style="height:38px; margin-top:-38px;">
                {$augmented_banner}
                </div>
                <div class="navigation">
sample: http://kb.gyyg.de

User avatar
edp
Someday Author
Posts: 93
Joined: Fri Sep 25, 2009 19:10

Re: Augmented Banner - now works with EDK 4.0.3

Post by edp » Tue Jun 06, 2017 02:00

With php7, I am getting the following error in my logs:

PHP 8192: Non-static method augmented_banner::add() should not be called statically in /var/www/kb/common/includes/class.event.php on line 71

User avatar
edp
Someday Author
Posts: 93
Joined: Fri Sep 25, 2009 19:10

Re: Augmented Banner - now works with EDK 4.0.3

Post by edp » Tue Jun 06, 2017 07:51

I fixed the issue with the PHP error by correcting the init.php file as follows:

Code: Select all

<?php
	if(!defined('KB_SITE')) die ("Go Away!");

	$modInfo['augmented_banner']['name'] = "augmented_banner";
	$modInfo['augmented_banner']['abstract'] = "Place top ranked avatar imaged in a banner bar";
	$modInfo['augmented_banner']['about'] = "Extended module";
	
	event::register("page_assembleheader", "augmented_banner::add");

	class augmented_banner
	{
		public static function add(&$home)
		{
			global $smarty;
    		include_once('mods/augmented_banner/augmented_banner.php');
			$smarty->assign("augmented_banner", $html);
		}
	}
?>

Rayven Kaundur
Noob
Posts: 8
Joined: Thu Jul 27, 2017 22:27

Re: Augmented Banner - now works with EDK 4.0.3

Post by Rayven Kaundur » Thu Jul 27, 2017 22:28

Is anyone using this with EDK 4.2.32.0 (YC-119.6 1.0)?

I've followed the directions here and have added the required line to my template but I am not seeing the banner

User avatar
Salvoxia
Developer
Posts: 1431
Joined: Wed Feb 22, 2012 12:11

Re: Augmented Banner - now works with EDK 4.0.3

Post by Salvoxia » Sun Jul 30, 2017 10:13

Hi,

I just tested it with the package from the opening post, works fine after modifying index.tpl as it says in the mod's settings.
You might need to clear your template cache (cache/templates_c).
If that doesn't do anything, could you post the contents of your active theme's index.tpl file?

Best Regards,
Salvoxia

Rayven Kaundur
Noob
Posts: 8
Joined: Thu Jul 27, 2017 22:27

Re: Augmented Banner - now works with EDK 4.0.3

Post by Rayven Kaundur » Sun Jul 30, 2017 12:58

Found my error, I had the

{$augmented_banner}

before the first

<div class="navigation">

instead of between the first

<div class="navigation"> and the first <table class="navigation" width="100%" style="height:25px;" border="0" cellspacing="1">.

Once I moved it, I am getting a space for the augmented banner to go, but I am not seeing anything there, just a blank line.

User avatar
Salvoxia
Developer
Posts: 1431
Joined: Wed Feb 22, 2012 12:11

Re: Augmented Banner - now works with EDK 4.0.3

Post by Salvoxia » Sun Jul 30, 2017 14:37

Hi,

by default, only the last 7 days are taken into account, so the killboard owners need to have kills within that timeframe. But I assume that's the case for you?

Best Regards,
Salvoxia

Rayven Kaundur
Noob
Posts: 8
Joined: Thu Jul 27, 2017 22:27

Re: Augmented Banner - now works with EDK 4.0.3

Post by Rayven Kaundur » Sun Jul 30, 2017 18:39

Well, hell's bell's that explains it. If you ain't got no kills, then you ain't gonna see a picture. :lol:

So, yes, that's why the banner space is there but empty, we ain't gots no kills. ;)

Post Reply

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 3 guests