Page 2 of 3

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 10:25
by Xeltor
I have it working on my own killboard and on my test killboard, give it a try and see if it works properly now :)

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 16:16
by pieboy87
I'm getting PHP errors when I switch my KB to monthly view and then check just kills or losses :(

Any ideas?

WARNING [2] cal_days_in_month(): invalid date.
Error on line 18 in file /var/www/kb/mods/fusioncharts/grafico.inc.php
PHP 5.3.5 (Linux), EDK 4.0.3 (Crucible)
File: /var/www/kb/mods/fusioncharts/grafico.inc.php, line: 18, function: cal_days_in_month
File: /var/www/kb/mods/fusioncharts/init.php, line: 48, function: GeneraDatiGrafico
File: /var/www/kb/common/includes/class.pageassembly.php, line: 80, function: call_user_func_array
File: /var/www/kb/common/includes/class.pageassembly.php, line: 44, class: pageAssembly, function: call
File: /var/www/kb/common/home.php, line: 736, class: pageAssembly, function: assemble
File: /var/www/kb/common/index.php, line: 293, function: include
File: /var/www/kb/index.php, line: 27, function: include

WARNING [2] Invalid argument supplied for foreach()
Error on line 363 in file /var/www/kb/mods/fusioncharts/grafico.inc.php
PHP 5.3.5 (Linux), EDK 4.0.3 (Crucible)
File: /var/www/kb/mods/fusioncharts/grafico.inc.php, line: 363, class: EDKError, function: handler
File: /var/www/kb/mods/fusioncharts/init.php, line: 48, function: VisualizzaGrafico
File: /var/www/kb/common/includes/class.pageassembly.php, line: 80, function: call_user_func_array
File: /var/www/kb/common/includes/class.pageassembly.php, line: 44, class: pageAssembly, function: call
File: /var/www/kb/common/home.php, line: 736, class: pageAssembly, function: assemble
File: /var/www/kb/common/index.php, line: 293, function: include
File: /var/www/kb/index.php, line: 27, function: include

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 17:50
by uri
Xeltor wrote:I have it working on my own killboard and on my test killboard, give it a try and see if it works properly now :)
still showing only losses :?

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 19:54
by Xeltor
pieboy87 wrote:I'm getting PHP errors when I switch my KB to monthly view and then check just kills or losses :(

Any ideas?

WARNING [2] cal_days_in_month(): invalid date.
Error on line 18 in file /var/www/kb/mods/fusioncharts/grafico.inc.php
PHP 5.3.5 (Linux), EDK 4.0.3 (Crucible)
File: /var/www/kb/mods/fusioncharts/grafico.inc.php, line: 18, function: cal_days_in_month
File: /var/www/kb/mods/fusioncharts/init.php, line: 48, function: GeneraDatiGrafico
File: /var/www/kb/common/includes/class.pageassembly.php, line: 80, function: call_user_func_array
File: /var/www/kb/common/includes/class.pageassembly.php, line: 44, class: pageAssembly, function: call
File: /var/www/kb/common/home.php, line: 736, class: pageAssembly, function: assemble
File: /var/www/kb/common/index.php, line: 293, function: include
File: /var/www/kb/index.php, line: 27, function: include

WARNING [2] Invalid argument supplied for foreach()
Error on line 363 in file /var/www/kb/mods/fusioncharts/grafico.inc.php
PHP 5.3.5 (Linux), EDK 4.0.3 (Crucible)
File: /var/www/kb/mods/fusioncharts/grafico.inc.php, line: 363, class: EDKError, function: handler
File: /var/www/kb/mods/fusioncharts/init.php, line: 48, function: VisualizzaGrafico
File: /var/www/kb/common/includes/class.pageassembly.php, line: 80, function: call_user_func_array
File: /var/www/kb/common/includes/class.pageassembly.php, line: 44, class: pageAssembly, function: call
File: /var/www/kb/common/home.php, line: 736, class: pageAssembly, function: assemble
File: /var/www/kb/common/index.php, line: 293, function: include
File: /var/www/kb/index.php, line: 27, function: include
Updated my code to use date("t"); instead of cal_days_in_month(); see if that fixes the problem.
uri wrote:still showing only losses :?
I can't replicate the problem on my test server, it seems to work fine for me.
http://test.corcoranstate.com/index.php/home/2011/12/
I don't have a clue why you only see losses :3

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 19:58
by uri
Xeltor wrote:
uri wrote:still showing only losses :?
I can't replicate the problem on my test server, it seems to work fine for me.
http://test.corcoranstate.com/index.php/home/2011/12/
I don't have a clue why you only see losses :3
you have 2 corps, we have 4 corps and 1 alliance, can be this the problem?
http://angelcartel.eve-online.es/killbo ... elf_detail

Re: [EDK 4.0.2] Fusioncharts

Posted: Tue Jan 17, 2012 23:33
by pieboy87
Thanks, the changes have fixed the erroring.

Doesnt seem to pull any data into the graph on the pages that previously errored, but that might be something my end.

Re: [EDK 4.0.2] Fusioncharts

Posted: Thu Jan 19, 2012 15:27
by Xeltor
uri wrote:
Xeltor wrote:
uri wrote:still showing only losses :?
I can't replicate the problem on my test server, it seems to work fine for me.
http://test.corcoranstate.com/index.php/home/2011/12/
I don't have a clue why you only see losses :3
you have 2 corps, we have 4 corps and 1 alliance, can be this the problem?
http://angelcartel.eve-online.es/killbo ... elf_detail
i'll make the same setup on my test server to see if i can get the same problems, probably something wrong with the SQL statement :P

Re: [EDK 4.0.2] Fusioncharts

Posted: Mon Jan 30, 2012 02:40
by uri
uri wrote:
Xeltor wrote:
uri wrote:still showing only losses :?
I can't replicate the problem on my test server, it seems to work fine for me.
http://test.corcoranstate.com/index.php/home/2011/12/
I don't have a clue why you only see losses :3
you have 2 corps, we have 4 corps and 1 alliance, can be this the problem?
http://angelcartel.eve-online.es/killbo ... elf_detail
ok, I saw today it detect 1 kill, it only show kills from alliance, losses from all, if I remove the alliance from killboard, it works perfect, check this please

Re: [EDK 4.0.2] Fusioncharts

Posted: Thu Apr 19, 2012 22:24
by noir
Fusioncharts just apear when I'm logged in. Wtf?!

Re: [EDK 4.0.2] Fusioncharts

Posted: Wed Feb 13, 2013 22:51
by idun
Repost from eve-id.net forums (24 Jan 2013) by Xeltor:
It's been a year since i'v been here and it seems i completely forgot about the problems that it had left.

They should however be fixed now, let me know how it goes.