[EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Discuss/Upload mods to the EVE-Dev Killboard.
User avatar
edp
Someday Author
Posts: 93
Joined: Fri Sep 25, 2009 19:10

Re: [EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Post by edp » Tue Jun 06, 2017 17:08

Glad to be of assistance!

nekses
Noob
Posts: 2
Joined: Tue Jan 30, 2018 17:43

Re: [EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Post by nekses » Tue Jan 30, 2018 17:50

by chance any idea why only battle overview and setup works?
Last edited by nekses on Mon Feb 05, 2018 17:08, edited 1 time in total.

User avatar
Salvoxia
Developer
Posts: 1465
Joined: Wed Feb 22, 2012 12:11

Re: [EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Post by Salvoxia » Tue Jan 30, 2018 20:03

Hi,

your Killboad is running on HTTPS.
The mod builds the AJAX URL to call when selecting each of the tabs. For some reason, it builds an URL beginning with "http://". The browser then blocks the AJAX call, since it's not allowed to dynamically load http URLs from an https URL.
In ACP -> Configuration, do you have "https://" set for your killboard host?

Best Regards,
Salvoxia

nekses
Noob
Posts: 2
Joined: Tue Jan 30, 2018 17:43

Re: [EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Post by nekses » Wed Jan 31, 2018 08:59

im running the server in http and using cloudflare for https. so serverside its http. any idea how i could adjust the code to work?

User avatar
Salvoxia
Developer
Posts: 1465
Joined: Wed Feb 22, 2012 12:11

Re: [EDK4] Combined Fleet Battles Mod (Updated 2017/06/05)

Post by Salvoxia » Wed Jan 31, 2018 15:06

Well, as long as you keep using cloudflare, setting the "Killboard host" in the Killboard's configuration to "https" should work. Which in turn should fix the problem.

Post Reply

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 7 guests