[MOD] WebGL Ship Display

Discuss/Upload mods to the EVE-Dev Killboard.
User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

[MOD] WebGL Ship Display

Post by prometh » Thu Jan 07, 2016 00:41

Hi all!

First of all this a mod of the existing ship display mod rather than a stand alone mod.

I uploaded a first version for testing here: https://bitbucket.org/snitchashor/ship_ ... /downloads (Extract and rename folder to ship_display_tool)

I do like ship spinning (who deosn't ?), but... A few month back a corp mate told me the new rendering engine makes the ships look so beautiful he wants to invite them out for dinner, I was more like "Huh, did they change something?" It turned out i had the GFX set too low to even realize a difference. So I set them to max and really liked the new look, however given my PC is rather low end, undocking turned out to be a bad idea. Since I spend a good amount of time by looking at killboards (mostly ours/mine) I decided to implement CCPs webgl rendering engine to get the nice looks and the abily to spin ships when looking at killmails. I agree its a more or less useless feature but hey it kinda works...

Heres an example (wait a while for the ship image to change): https://brgf.de/kb/?a=kill_detail&kll_id=37354

Features:
  • 3D ship display of all currently available ships and deployables (Ascensiin) (Didn't try all though)
  • Current Image as "loading" and fallback image
  • Different Nebula for different races
  • T3 Cruiser show actual layout based on susystems (see here: https://brgf.de/kb/index.php/kill_detail/37008/)
  • Display mounted Turrets/Launchers (they even fire once in a while)
  • Dreads and Marauder enter and exit Siege
  • Turrets are turned off on Mobiles for performance reasons
  • T3 Dessies switch modes
  • Show Hardeners/Boosters/Repairers (optionally)
ToDo:
  • Missiles
  • Drones...
  • Loading indicator
  • EXPLOSIONS
Cons:
  • Not exactly blazing fast
  • Needs an additional Database Table (type2graphic ids) that need to be maintained
  • Increased traffic on the client side (not your webserver, files are delivered via a CCP CDN)
  • M$^$&*^%ft decided not to do a propper webgl implementation so on IE and Edge it doesnt look that nice
What do you think?

Cheers, Snitch

P.S.: I did all the style work using Vecati's EVE+ Theme, if the result does not look good for your theme, try replacing the mods Stylesheet with this one:
style.zip
(3.83 KiB) Downloaded 184 times
Latest update 02/05/16:
v3.7-Snitch1.08
- Added support for Ascension ressources
- Database reworked
! This one needs a database update, to be done in the mod settings, Drop and reimport !

v3.7-Snitch1.07
- Added support for Citadels ressources
- Minor fixes

Last but not least a few credits:

Chris Sheppard and Salvoxia for the original mod
DB conversions were done using Fuzzy Steves static dump.
CCP for the webgl project.
CPPC Tamber and CCP fillipppavlov for a lot of help.
Last edited by prometh on Tue Nov 22, 2016 09:30, edited 12 times in total.

User avatar
Salvoxia
Developer
Posts: 1516
Joined: Wed Feb 22, 2012 12:11

Re: WIP WebGL Ship Display

Post by Salvoxia » Fri Jan 08, 2016 11:52

Hi,

that's pretty impressive!
I guess you'll need a Github account after all ;P

Some questions:
The YAML files are required because most of the code is Javascript?
If you release a publicly available version, would you be willing to maintain it and provide updates for the YAML files (I thought about generating them from the EDK database, but that unfortunately does not include graphicIDs)?

Best Regards,
Salvoxia

User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: WIP WebGL Ship Display

Post by prometh » Fri Jan 08, 2016 17:21

Thanks!

It's actually not yaml files but mysql conversions of two yaml files to make the connection from ship type to graphic ids. I did some preliminary version that can install/update those two sql tables from the admin/settings page but the code for this is really ugly.

I will upload a version the coming days, however I'm still not sure whether the ccp webgl files can be ported to different webservers easily.


Image

User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh » Sat Jan 09, 2016 14:56

I just uploaded a first Version for testing that has a few improvements/add ons.

Happy testing.


Image

User avatar
Salvoxia
Developer
Posts: 1516
Joined: Wed Feb 22, 2012 12:11

Re: [MOD] WebGL Ship Display

Post by Salvoxia » Tue Jan 26, 2016 12:56

Hi,

klicking around at The Bloc killboard I found an issue with "ships" that are not available in WebGL, more specificly with DUST514 kills. When viewing such a kill, the Javascript error console goes completely nuts (seems to be polling whether loading is complete and throws an error each time, but won't stop).

Link: https://bloc.ga/kb/index.php/kill_detail/88752/
Javascript error spammed:

Code: Select all

IsStillLoadingError: Cannot process the request until the object is loaded
Best Regards,
Salvoxia

User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh » Tue Jan 26, 2016 17:13

Thanks for that one, I have to check how to get rid of these, maybe for now I'll tell people to stop orbital bombardments...
Right now the Bloc killboard is sort of my dev board since I thought nobody was looking at it anyway.

Edit: Fixed it, or at least it gives a meaningful error message and does not go into a loop now


Image

3psylon
Noob
Posts: 7
Joined: Mon May 25, 2015 14:19

Re: [MOD] WebGL Ship Display

Post by 3psylon » Tue Feb 09, 2016 15:47

Nice mod, i like it!!

I've some problems:

DEPRECATED [8192] Non-static method Calculations::calculateMass() should not be called statically, assuming $this from incompatible context
Error on line 552 in file /home/avalonfcgj/www/killboard/mods/ship_display_tool/Libs/Fitting.class.php
PHP 5.6.15 (Linux), EDK 4.2.18.0 (YC-118-1 1.0)
File: /home/avalonfcgj/www/killboard/mods/ship_display_tool/Libs/Fitting.class.php, line: 552, class: EDKError, function: handler
File: /home/avalonfcgj/www/killboard/mods/ship_display_tool/init.php, line: 332, class: Fitting, function: getShipStats
File: /home/avalonfcgj/www/killboard/common/includes/class.pageassembly.php, line: 80, function: call_user_func_array
File: /home/avalonfcgj/www/killboard/common/includes/class.pageassembly.php, line: 44, class: pageAssembly, function: call
File: /home/avalonfcgj/www/killboard/common/kill_detail.php, line: 1731, class: pageAssembly, function: assemble
File: /home/avalonfcgj/www/killboard/common/index.php, line: 319, function: include
File: /home/avalonfcgj/www/killboard/index.php, line: 27, function: include

User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh » Thu Feb 11, 2016 18:18

hmmm that one somehow sneaked back in... should be fixed now. Just redownload from bitbucket, upload, clear cache and that warning should be gone.

Cheers


Image

DanZorg
Noob
Posts: 7
Joined: Mon Feb 15, 2016 05:49

Re: [MOD] WebGL Ship Display

Post by DanZorg » Mon Feb 15, 2016 08:02

I've installed the mod - seems to work - i can activate and pages load, however the WebGL Portion never seems to load.

Server is using PHP7 (as it is a development board) could this be the issue?

http://cnet-killboard.cloudapp.net/kill ... _detail/2/

User avatar
prometh
Advanced
Posts: 169
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh » Mon Feb 15, 2016 08:47

DanZorg wrote:
Mon Feb 15, 2016 08:02
I've installed the mod - seems to work - i can activate and pages load, however the WebGL Portion never seems to load.

Server is using PHP7 (as it is a development board) could this be the issue?

http://cnet-killboard.cloudapp.net/kill ... _detail/2/
hmmm it behaves as if it wasn't activated... could you double check if the webgl part is activated in the admin section under modules/shid_display_tool? If it is, I can make a force enabled version and try to debug that.


Image

Post Reply

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 9 guests