[MOD] WebGL Ship Display

Discuss/Upload mods to the EVE-Dev Killboard.
User avatar
prometh
Advanced
Posts: 170
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh »

I pushed a quick fix without really investigating the potential collaterals but there should be very few. So either redownload the mod or open the Libs/Fitting.class.php file and change line 283:

Code: Select all

                        foreach($_modData[$_mods->item_->getAttribute('typeID')] as $att => $modAttributes) {
to

Code: Select all

                        foreach((array)$_modData[$_mods->item_->getAttribute('typeID')] as $att => $modAttributes) {
Cheers,
Snitch

User avatar
prometh
Advanced
Posts: 170
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh »

Updated to latest CCP javascript:

If your killboard was not running over ssl (https) you might have experienced issues getting the webgl ressources once in a while (CORS warnings if you examined more closely). These should be mostly gone.

User avatar
prometh
Advanced
Posts: 170
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh »

Update to work with the Citadels release ships and structures:

v3.7-Snitch1.07
- Added support for Citadels ressources
- Minor fixes
! This one needs a database update, to be done in the mod settings !

If Force Auxilaries show up as carrier, clear cache. If the problem persists, updating the database failed (For manual updates, it's Sql/yamlwebgl.sql). Please let me know if this happens.

Cheers,
Snitch

Explorus
Greenhorn
Posts: 22
Joined: Thu Oct 18, 2012 08:20

Re: [MOD] WebGL Ship Display

Post by Explorus »

awesome mod!

User avatar
prometh
Advanced
Posts: 170
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh »

Explorus wrote:
Sat May 28, 2016 23:34
awesome mod!
Glad you like it.
Theres more to come but it turns out having drones orbiting the ship is not that easy...

User avatar
prometh
Advanced
Posts: 170
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] WebGL Ship Display

Post by prometh »

Updated for Ascension.

Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Re: [MOD] WebGL Ship Display

Post by Bas »

https://kb.d3ath.ru/?a=kill_detail&kll_id=148163

Code: Select all

2016/12/09 14:33:29 [error] 85355#101238: *486405 FastCGI sent in stderr: "PHP message: PHP 2:  Division by zero in /.../kb/mods/ship_display_tool/init.php on line 1635
PHP message: PHP 2:  Division by zero in /.../kb/mods/ship_display_tool/init.php on line 1635
PHP message: PHP 2:  Division by zero in /.../kb/mods/ship_display_tool/init.php on line 1635
PHP message: PHP 2:  Division by zero in /.../kb/mods/ship_display_tool/init.php on line 1635" while reading ...
Catched ;]

User avatar
Rayven Kaundur
Greenhorn
Posts: 21
Joined: Thu Jul 27, 2017 22:27

Re: [MOD] WebGL Ship Display

Post by Rayven Kaundur »

I know it has been awhile since anything was posted here, but I am getting this error when displaying a kill:

[Mon Oct 02 11:49:37.900589 2017] [:error] [pid 16422] [client 75.109.16.63:59867] PHP 8192: Non-static method init_serverstatus::handler() should not be called statically in /var/www/kb/common/includes/class.event.php on line 71
[Mon Oct 02 11:49:37.901069 2017] [:error] [pid 16422] [client 75.109.16.63:59867] PHP 8192: Non-static method serverstatus::display() should not be called statically in /var/www/kb/common/includes/class.pageassembly.php on line 80

User avatar
Salvoxia
Developer
Posts: 1598
Joined: Wed Feb 22, 2012 12:11

Re: [MOD] WebGL Ship Display

Post by Salvoxia »

Hi,

this looks more like an error produced by the Server status mod, caused by an incompatibility to PHP7.
I updated the mod to no longer produce this problem, please follow the link and download the version for PHP7.

Best Regards,
Salvoxia

Post Reply