[MOD] Stats and SSO mod

Discuss/Upload mods to the EVE-Dev Killboard.
Kold
Noob
Posts: 6
Joined: Sun Oct 23, 2016 02:40

Re: [MOD] Stats and SSO mod

Post by Kold » Sat Oct 29, 2016 05:01

I have some issues with the save fitting feature. Dev side is set up to be able to read/write fittings.

After SSO login I try to save a fitting...
http://www.arvo.space/kb/sso_login&meth ... F&fit=166/

Currently my KBs are in subdir of the root of a wordpress site.

I disable the WP .httacess the error message is such.

Code: Select all

The requested URL /kb/sso_login&method=savefit&page=://arvo.space/kb/index.php/kill_detail/166/&fit=166/ was not found on this server.
Anyone come across this before?

User avatar
prometh
Advanced
Posts: 167
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] Stats and SSO mod

Post by prometh » Tue Nov 01, 2016 13:14

Kold wrote:
Sat Oct 29, 2016 05:01
I have some issues with the save fitting feature. Dev side is set up to be able to read/write fittings.

After SSO login I try to save a fitting...
http://www.arvo.space/kb/sso_login&meth ... F&fit=166/

Currently my KBs are in subdir of the root of a wordpress site.

I disable the WP .httacess the error message is such.

Code: Select all

The requested URL /kb/sso_login&method=savefit&page=://arvo.space/kb/index.php/kill_detail/166/&fit=166/ was not found on this server.
Anyone come across this before?
I'll have a look. The constructed url is wrong, it's missing the /index.php/ part for whatever reason. Also for the return url for whatever reason is lacking the http(s) and is a weird mix of simple and non-simple urls

nefrit
Apprentice
Posts: 56
Joined: Sun Mar 10, 2013 21:10

Re: [MOD] Stats and SSO mod

Post by nefrit » Tue Nov 01, 2016 21:13

Parse error: syntax error, unexpected '[', expecting ')' in /var/www/mods/statsmod/sso_login.php on line 41

http://raccoon-company.com/index.php/ss ... mpany.com/

:(

Image

User avatar
prometh
Advanced
Posts: 167
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] Stats and SSO mod

Post by prometh » Wed Nov 02, 2016 00:54

nefrit wrote:
Tue Nov 01, 2016 21:13
Parse error: syntax error, unexpected '[', expecting ')' in /var/www/mods/statsmod/sso_login.php on line 41

http://raccoon-company.com/index.php/ss ... mpany.com/

:(

Image
Which php version are you running? And could you please check the vendor subfolder is present and complete?


Image

nefrit
Apprentice
Posts: 56
Joined: Sun Mar 10, 2013 21:10

Re: [MOD] Stats and SSO mod

Post by nefrit » Wed Nov 02, 2016 08:13

o7

php 5.3 and we can use 5.4-5.6 or 7.0
statsmod folder from https://bitbucket.org/snitchashor/stats ... od-0.3.zip ?

UPD sorry for this :oops: change php version on 7/0 and its work.
Thanks !

User avatar
prometh
Advanced
Posts: 167
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] Stats and SSO mod

Post by prometh » Wed Nov 02, 2016 11:32

The oauth library I used requires php 5.5+


Image

User avatar
prometh
Advanced
Posts: 167
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: [MOD] Stats and SSO mod

Post by prometh » Wed Nov 02, 2016 13:25

Kold wrote:
Sat Oct 29, 2016 05:01
I have some issues with the save fitting feature. Dev side is set up to be able to read/write fittings.

After SSO login I try to save a fitting...
http://www.arvo.space/kb/sso_login&meth ... F&fit=166/

Currently my KBs are in subdir of the root of a wordpress site.

I disable the WP .httacess the error message is such.

Code: Select all

The requested URL /kb/sso_login&method=savefit&page=://arvo.space/kb/index.php/kill_detail/166/&fit=166/ was not found on this server.
Anyone come across this before?
Turns out I broke simple urls when trying to fix the non-simple urls. Can you try this version: statsmod-0.4? And please clear the cache after updating.

Bests,
Snitch


Image

nefrit
Apprentice
Posts: 56
Joined: Sun Mar 10, 2013 21:10

favorite ships (all time)

Post by nefrit » Fri Nov 04, 2016 13:45

о7

Image
what does it mean ?

curse - industrial ? :shock:

User avatar
Salvoxia
Developer
Posts: 1464
Joined: Wed Feb 22, 2012 12:11

Re: [MOD] Stats and SSO mod

Post by Salvoxia » Fri Nov 04, 2016 19:47

I took the liberty to move this post from the Support forum into this thread, as it concerns this mod.

User avatar
prometh
Advanced
Posts: 167
Joined: Thu Aug 09, 2012 19:25
Contact:

Re: favorite ships (all time)

Post by prometh » Sat Nov 05, 2016 00:19

nefrit wrote:
Fri Nov 04, 2016 13:45
о7

Image
what does it mean ?

curse - industrial ? :shock:
Yeah there was some mix up between attackers and victims...
Fixed in this one.

Bests,
Snitch


Image

Post Reply

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 7 guests