API Import Bug in 3.2.0

Please report bugs here, please be very detailed in your bug reports. If you've come up with some code to fix the bug, please post it here.
Post Reply
Zaine
Greenhorn
Posts: 16
Joined: Sun Jul 05, 2009 14:45

API Import Bug in 3.2.0

Post by Zaine » Fri Jan 21, 2011 00:56

--
WARNING [2] Invalid argument supplied for foreach()
Error on line 34 in file ....../killboard2/common/includes/api/class.char.php
PHP 5.2.9 (Linux), EDK 3.2.0 Alpha (Incursion)
File: ....../killboard2/common/includes/api/class.char.php, line: 34, class: EDKError, function: handler
File: ....../killboard2/common/admin/admin_apimod.php, line: 47, class: API_Char, function: fetch
File: ....../killboard2/common/index.php, line: 342, function: include
File: ....../killboard2/index.php, line: 26, function: include
--

Older version of board running on http://www.innsmouthenterprises.com/killboard, and 3.2.0 version in http://www.innsmouthenterprises.com/killboard2/

The API was working fine in the old board, but not on the new with the same details. I generated a new key, and added those details to killboard2 and got the above errors. I guess this could be down to the 10min new api key lag?

Zaine
Greenhorn
Posts: 16
Joined: Sun Jul 05, 2009 14:45

Re: API Import Bug in 3.2.0

Post by Zaine » Wed Dec 07, 2011 16:29

and the error has now gone away? Perhaps to do with this message disappearing "A new Full Access API Key has been generated for your account. Authentication using this new key may take up to ten minutes to begin working." on http://www.eveonline.com/api/default.as ... full_key=1

Zaine
Greenhorn
Posts: 16
Joined: Sun Jul 05, 2009 14:45

Re: API Import Bug in 3.2.0

Post by Zaine » Wed Dec 07, 2011 16:30

Oops. Didn't mean to bump. I just installed edk4 and got a very similar set of errors with a new Corp key:

Code: Select all

WARNING [2] Invalid argument supplied for foreach()
Error on line 65 in file /home/innsmout/public_html/killboardv4/common/includes/api/class.killlog.php
PHP 5.2.9 (Linux), EDK 4.0.1 (Crucible)
File: /home/innsmout/public_html/killboardv4/common/includes/api/class.killlog.php, line: 65, class: EDKError, function: handler
File: /home/innsmout/public_html/killboardv4/common/admin/admin_api.php, line: 118, class: API_KillLog, function: Import
File: /home/innsmout/public_html/killboardv4/common/index.php, line: 293, function: include
File: /home/innsmout/public_html/killboardv4/index.php, line: 27, function: include

WARNING [2] file_get_contents() [function.file-get-contents]: Filename cannot be empty
Error on line 117 in file /home/innsmout/public_html/killboardv4/common/includes/class.idfeed.php
PHP 5.2.9 (Linux), EDK 4.0.1 (Crucible)
File: /home/innsmout/public_html/killboardv4/common/includes/class.idfeed.php, line: 117, function: file_get_contents
File: /home/innsmout/public_html/killboardv4/common/includes/api/class.killlog.php, line: 124, class: IDFeed, function: read
File: /home/innsmout/public_html/killboardv4/common/admin/admin_api.php, line: 118, class: API_KillLog, function: Import
File: /home/innsmout/public_html/killboardv4/common/index.php, line: 293, function: include
File: /home/innsmout/public_html/killboardv4/index.php, line: 27, function: include

WARNING [512] Error reading file.
Error on line 118 in file /home/innsmout/public_html/killboardv4/common/includes/class.idfeed.php
PHP 5.2.9 (Linux), EDK 4.0.1 (Crucible)
File: /home/innsmout/public_html/killboardv4/common/includes/class.idfeed.php, line: 118, function: trigger_error
File: /home/innsmout/public_html/killboardv4/common/includes/api/class.killlog.php, line: 124, class: IDFeed, function: read
File: /home/innsmout/public_html/killboardv4/common/admin/admin_api.php, line: 118, class: API_KillLog, function: Import
File: /home/innsmout/public_html/killboardv4/common/index.php, line: 293, function: include
File: /home/innsmout/public_html/killboardv4/index.php, line: 27, function: include

wyattwic
Active Author
Posts: 140
Joined: Wed Sep 01, 2010 08:21

Re: API Import Bug in 3.2.0

Post by wyattwic » Wed Dec 07, 2011 23:26

Looks like its been fixed in the test release....

Try this GIT command for the newest version (e7e26b5c0c47)

Code: Select all

git clone https://code.google.com/p/evedev-kb/
NOTE: No longer in game!


A question that sometimes drives me hazy: am I or are the others crazy?
Logic will get you from A to B. Imagination will take you everywhere.

Post Reply

Return to “Bug Reporting”

Who is online

Users browsing this forum: No registered users and 11 guests