Can't find anything + api import fails

Please report bugs here, please be very detailed in your bug reports. If you've come up with some code to fix the bug, please post it here.
Post Reply
GeneralAlex
Noob
Posts: 2
Joined: Fri Nov 30, 2012 17:44

Can't find anything + api import fails

Post by GeneralAlex » Fri Nov 30, 2012 17:53

0/
I get the same trouble multiple times in my hosting.
I'm using EDK 4-04.
When I'm installing KB, on step 5 I can't find anything. I tried any known alliances and pilots, the board can't find none of them.
The same thing with corporations.
Moving forward.
After installations, when I'm trying to import api key, I got errors:

WARNING [2] Invalid argument supplied for foreach()
Error on line 320 in file /home/rpbeve/rpb-eve.ru/killboard/common/admin/admin_api.php
PHP 5.4.9 (Linux), EDK 4.0.4 (Crucible)
File: /home/rpbeve/rpb-eve.ru/killboard/common/admin/admin_api.php, line: 320, class: EDKError, function: handler
File: /home/rpbeve/rpb-eve.ru/killboard/common/index.php, line: 293, function: include
File: /home/rpbeve/rpb-eve.ru/killboard/index.php, line: 27, function: include


I tried that api key in free hosting kb service, it's working.

I want that my corporations have its own, hosting-based killboard. Not free version ('cause they need isks, I used eve-sco).
But I can't understood where are problems - in kb files or database.
Please help me.
:idea: :!:

ConradSyld
Greenhorn
Posts: 19
Joined: Mon Aug 22, 2011 01:01

Re: Can't find anything + api import fails

Post by ConradSyld » Fri Nov 30, 2012 18:49


GeneralAlex
Noob
Posts: 2
Joined: Fri Nov 30, 2012 17:44

Re: Can't find anything + api import fails

Post by GeneralAlex » Fri Nov 30, 2012 19:26

Fixed api key import.
But still erorrs

WARNING [2] Invalid argument supplied for foreach()
Error on line 594 in file /home/rpbeve/rpb-eve.ru/killboard/common/includes/class.killsummarytable.php
PHP 5.4.9 (Linux), EDK 4.0.4 (Crucible)
File: /home/rpbeve/rpb-eve.ru/killboard/common/includes/class.killsummarytable.php, line: 594, class: EDKError, function: handler
File: /home/rpbeve/rpb-eve.ru/killboard/common/corp_detail.php, line: 171, class: KillSummaryTable, function: generate
File: /home/rpbeve/rpb-eve.ru/killboard/common/includes/class.pageassembly.php, line: 70, function: call_user_func_array
File: /home/rpbeve/rpb-eve.ru/killboard/common/includes/class.pageassembly.php, line: 37, class: pageAssembly, function: call
File: /home/rpbeve/rpb-eve.ru/killboard/common/corp_detail.php, line: 715, class: pageAssembly, function: assemble
File: /home/rpbeve/rpb-eve.ru/killboard/common/index.php, line: 293, function: include
File: /home/rpbeve/rpb-eve.ru/killboard/index.php, line: 27, function: include

idun
Developer
Posts: 152
Joined: Tue Mar 16, 2010 06:30

Re: Can't find anything + api import fails

Post by idun » Fri Mar 15, 2013 14:39

This was resolved in the old forums before migrating over to the new host, but to answer here:

Use the install_step5 file from git-head (download and replace in /install):
https://code.google.com/p/evedev-kb/sou ... _step5.php

Post Reply

Return to “Bug Reporting”

Who is online

Users browsing this forum: No registered users and 8 guests