Killmails w/o alliance become with my alliance id

Please report bugs here, please be very detailed in your bug reports. If you've come up with some code to fix the bug, please post it here.
Post Reply
Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Killmails w/o alliance become with my alliance id

Post by Bas » Thu Dec 17, 2015 11:20

Current version: 4.2.17.0 (Frostline 1.0)
Mods: allicorpstats_page, corp_top_killers, fleet_battles_mod, most_expensive_mod, ship_display_tool

Clearing cache and disabling all mods didn't resolve the issue.
My alliance id in DB is 2.

Bugged Mail #1:
https://kb.d3ath.ru/?a=kill_detail&kll_id=108799
CREST: https://public-crest.eveonline.com/kill ... 6d999d4f5/
Zkb: https://zkillboard.com/kill/50755559/
Was deleted and reposted manualy with CREST and now looks ok.

Bugged Mail #2:
https://kb.d3ath.ru/?a=kill_detail&kll_id=108734
Killmail: https://kb.d3ath.ru/?a=kill_mail&kll_id=108734
CREST: https://public-crest.eveonline.com/kill ... 5fcfdf23e/
Zkb: https://zkillboard.com/kill/50755222/
Pilot not in alliance, but kb assign my alli id o_O
CREST shows no alliance, but killboard find another way ;]

Bugged Mail #3:
https://kb.d3ath.ru/?a=kill_detail&kll_id=108737
Killmail: https://kb.d3ath.ru/?a=kill_mail&kll_id=108737
CREST: https://public-crest.eveonline.com/kill ... 5ffb4c885/
Zkb: https://zkillboard.com/kill/50755504/
Same as above

User avatar
Salvoxia
Developer
Posts: 1515
Joined: Wed Feb 22, 2012 12:11

Re: Killmails w/o alliance become with my alliance id

Post by Salvoxia » Thu Dec 17, 2015 17:01

Hi,

thank you for reporting, I will take a look.

Best Regards,
Salvoxia

User avatar
Salvoxia
Developer
Posts: 1515
Joined: Wed Feb 22, 2012 12:11

Re: Killmails w/o alliance become with my alliance id

Post by Salvoxia » Sat Dec 19, 2015 10:57

Hi,

I looked at the code and at the kills. I was not able to reproduce the problem. There are only two situations in which this could have happened: Either a corrupted cache at EDK, or a hic-up at zKillboard.
I looked at other EDKs fetching from zKillboard, trying to find kills that were fetched roughly at the same time, but at those there was everything ok.
The pattern I found looks like this: It seems that all Victims/Involved Parties in kills that were fetched from zKillboard at Dec 16 20:40:00 that are not in any alliance (using a pseudo-alliance with ID 3) were moved to your alliance (with ID 2). The only kills affected seem from this batch, the fetched kills before and after that time seem to be OK.
I don't see what I could do right now, but please be sure to report back if anything like this happens again.

Regards,
Salvoxia

Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Re: Killmails w/o alliance become with my alliance id

Post by Bas » Sun Dec 20, 2015 13:48

Tnx for reply. I've another issue with wrong alliance id and I starting to think that you are right about cache.
Few days ago users reported about killmail, where all alliance members have alliance id 4 instead of 2.
Killmail was deleted, added via CREST and alliance id is correct now.

I will try to catch such bugged mails and try to refetch from zkb instead of CREST.

Post Reply

Return to “Bug Reporting”

Who is online

Users browsing this forum: No registered users and 2 guests