Redis super cache

Please report bugs here, please be very detailed in your bug reports. If you've come up with some code to fix the bug, please post it here.
Post Reply
Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Redis super cache

Post by Bas » Mon Jan 09, 2017 16:03

Hello!

Code: Select all

$ php -v
PHP 5.6.28 (cli) (built: Dec  1 2016 01:23:07)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

Code: Select all

Redis 3.2.4

Code: Select all

Global lifetime: 5 (minutes)
..., but I tried to change to 1, 2 minutes too.

Redis performance looks much more better on big killboards. I have 4 killboard instances and I started to use Redis instead of Memcached. Also I have 2 cronjobs to fetch killmails from EVE API (00,30 * * * *) and 2 cronjobs to fetch killmails from ZKB (15,45 * * * *). As I known cache will be cleared when new killmail will be added. Unfortunately, I catch a lot of cases when killboard didn't clear cache and main page "freezes" for 1 or 2 hours :( Clear File Cache resolve the problem for a short time. I enabled Memcached back on one of killboards and looks like main page update correctly.

User avatar
Salvoxia
Developer
Posts: 1518
Joined: Wed Feb 22, 2012 12:11

Re: Redis super cache

Post by Salvoxia » Tue Jan 10, 2017 21:25

I could not find any crucial differences between the Memcached cache handler and the Redis one.
What is your "Pages updated every kill" setting?

Best Regards,
Salvoxia

Bas
Apprentice
Posts: 65
Joined: Sun Apr 20, 2014 12:11
Location: Russia, Moscow
Contact:

Re: Redis super cache

Post by Bas » Wed Jan 11, 2017 01:59

Salvoxia wrote:
Tue Jan 10, 2017 21:25
What is your "Pages updated every kill" setting?
Only "home" in this setting. Atm i use memcached server instead of Redis. With Memcached i have no this problem.
3.png
3.png (31.09 KiB) Viewed 2300 times

Post Reply

Return to “Bug Reporting”

Who is online

Users browsing this forum: No registered users and 1 guest